Support Unavailable to Call
Incident Report for Gradwell Communications Ltd
Resolved
The Support Teams are now able to handle calls.

Please accept our apologies for any inconvenience caused.
Posted Jan 14, 2020 - 10:33 GMT
Investigating
We are aware of an issue with the phones lines when contacting our Support Teams, resulting in the team not being able to pick up any calls.

This is being investigated as a matter of urgency and we will update you as soon as possible.

In the meantime please email the teams partnersupport@gradwell.com / customersupport@gradwell.com, where a member of the team will be able to assist you with your inquiry.

We apologise for any inconvenience this causes
Posted Jan 14, 2020 - 08:10 GMT
This incident affected: Portals and Website (Gradwell team).