Gradwell Support Calls Intermittently Failing
Incident Report for Gradwell Communications Ltd
Resolved
We have now received confirmation from our supplier that this has been resolved.
Please accept our apologies for any inconvenience caused.
Posted Apr 17, 2018 - 14:34 BST
Investigating
The Gradwell Support teams' inbound calls are currently affected by a service fault with our supplier. This may cause calls to the support team to intermittently fail.

While this incident is ongoing, please contact the support team by email to support@gradwell.com or partnersupport@gradwell.com.

We apologise for any inconvenience this may cause. This status will be updated with further information by 14:00.
Posted Apr 17, 2018 - 12:17 BST
This incident affected: Portals and Website (Gradwell team).