Inbound Email Failures
Incident Report for Gradwell Communications Ltd
Resolved
Following work completed by our engineers, all users previously blocked by quarantine have now been released. We will be completing an internal investigation into the cause of this incident.

If customers are still experiencing problems with their service, please close and reopen any mail clients before contacting support. Support can be contacted on 01225 800888 or by emailing support@gradwell.com.

Please accept our apologies for any inconvenience this incident may have caused.
Posted Jul 11, 2017 - 16:03 BST
Identified
Our engineers have identified the cause of this issue and are in the process of implementing the resolution.

We apologise for any inconvenience this may cause. A further update will be post by 16:15.
Posted Jul 11, 2017 - 15:47 BST
Investigating
Following the errors seen earlier today, we have received reports of inbound email to hosted exchange users being bounced back to sender, due to the exchange users being quarantined.

Our engineers are currently investigating this behaviour. Customers using Gradwell Hosted Exchange (HEX) services may see inbound email delivery failures. Please note that this incident does not affect customers using regular POP3 or IMAP mail services.

Please accept our apologies for the inconvenience this may cause. A further update will be posted by 16:15.
Posted Jul 11, 2017 - 15:39 BST