Issues accessing the Gradwell Control Panel via http://sso.gradwell.com
Incident Report for Gradwell Communications Ltd
Resolved
We can confirm this issue has now been resolved and apologise for any inconvenience this may have caused.
Posted Apr 14, 2020 - 10:23 BST
Investigating
We are currently investigating issues accessing the Gradwell Control Panel via http://sso.gradwell.com. We will provide an update at 11AM.

We apologise for any inconvenience this may cause
Posted Apr 14, 2020 - 09:27 BST
This incident affected: Portals and Website (Gradwell customer control panels).