Inbound & Outbound Call Failures
Incident Report for Gradwell Communications Ltd
Postmortem

Reason For Outage – Call Failures 25th March 2022

Issued 31/03/2022

For external use

  • Time: 08:05 - 11:25
  • Duration: 3 hours, 20 minutes
  • Description of outage: At 08:05 on the 25th of March 2022, Gradwell systems detected an issue impacting outbound calls causing them to drop. At any given time no more than 10% of our telephony platform was impacted by this outage. The issue would have presented as dropping calls. Gradwell Engineers were fully engaged on the incident which was given a priority one status.
  • Cause & Resolution: Our engineers identified the cause of the issue, compiled a fix and deployed this throughout the affected infrastructure by 11:23. No further failures were observed after the fix had been deployed.
  • Root Cause: The issue occurred within the Asterisk project and affected all users of the Asterisk platform globally. A fix has been suggested by Asterisk on 30/03/2022 and is being tested externally.
  • Prevention of recurrence: Gradwell engineers designed and deployed a fix internally to mitigate the risks of recurrence.
Posted Mar 31, 2022 - 11:29 BST

Resolved
Hello,

The service outage has now been resolved following the release of the fix. We will be providing a Reson For Outage (RFO) in due course.

Kind Regards,
Gradwell Service Team
Posted Mar 25, 2022 - 14:40 GMT
Monitoring
Hi,

A fix has been released and calls are returning to normal. We will monitor the issues to ensure the issue does not reoccur.

If you are still having issues, please call our support team.
Please accept our sincerest apologies for the inconvenience caused.
Posted Mar 25, 2022 - 12:24 GMT
Identified
Hello,

We are in the process of rolling out a fix for the reported issues. We will provide another update at 12pm

Please accept our sincerest apologies for the inconvenience caused.
Posted Mar 25, 2022 - 10:50 GMT
Update
Hello,

We are still investigating the problem, however the calls are starting to return to normal.

We'll provide a further update at 10:45am. Please accept our sincerest apologies for the inconvenience caused.
Posted Mar 25, 2022 - 10:20 GMT
Update
Hello,

We are still investigating the problem. Our engineers are fully engaged in resolving the urgent issue.

Please accept our sincerest apologies for the inconvenience caused. We will provide the next update at 10:15am
Posted Mar 25, 2022 - 09:44 GMT
Investigating
Hello,

We are currently investigating inbound call failures where the calls are dropping audio. We are investigating this as a P1 fault and will update you in due course.

Please accept our sincerest apologies for the inconvenience caused.
Posted Mar 25, 2022 - 09:24 GMT
This incident affected: Voice & Calls Services (Multi User VoIP, Inbound SIP trunking, Inbound IAX Trunking, Single User VoIP).