Slow speeds on Broadband connections
Incident Report for Gradwell Communications Ltd
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 10:23 GMT
Monitoring
A fix has been implemented and we believe the issue to be resolved. If you have any further issues with slow speed, please contact our support team on 01225 800888.

We sincerely apologise for any inconvenience caused during this time.
Posted Jan 26, 2021 - 10:23 GMT
Investigating
Following last nights outage, we are seeing reports from customers who are receiving slow speeds on their broadband line.
This is currently being investigated as a priority.

Please accept our sincerest apologies for the inconvenience caused.

We will provide an update at 10:30am
Posted Jan 26, 2021 - 09:52 GMT
This incident affected: Connectivity (Fibre line, EFM, ADSL Broadband, FTTC, Phone lines).