Reduced Support Availability
Incident Report for Gradwell Communications Ltd
Resolved
This incident has been resolved.
Posted Oct 18, 2018 - 10:31 BST
Monitoring
The Gradwell Support team is currently experiencing longer call wait times and slower ticket response due to widespread illness in the department.
During this time we would recommend customers raise issues to the team by email to support@gradwell.com.

Please accept our apologies for any inconvenience this may cause.
Posted Oct 15, 2018 - 10:57 BST
This incident affected: Portals and Website (Gradwell team).