[Scheduled] Gradwell Support Training
Incident Report for Gradwell Communications Ltd
Resolved
Our support team are no longer in training. Support response times and levels will return to normal over the next few days.

We apologise for any inconvenience this may have caused.
Posted Oct 04, 2017 - 16:54 BST
Identified
Due to training, our support numbers will be at reduced levels today and tomorrow, 3rd and 4th October.

Please accept our apologies for the short notice. If you are unable to get through to the support number, please submit a support ticket and one of our support agents will respond as soon as possible.
Posted Oct 03, 2017 - 09:51 BST
Investigating
Due to training, our support numbers will be at reduced levels today and tomorrow, 3rd and 4th October.

Please accept our apologies for the short notice. If you are unable to get through to the support number, please submit a support ticket and one of our support agents will respond as soon as possible.
Posted Oct 03, 2017 - 09:26 BST