Inbound support call failures to Gradwell support team
Incident Report for Gradwell Communications Ltd
Resolved
This issue has been resolved and our support team are able to receive calls again.

We apologise for any inconvenience caused.
Posted Jan 13, 2017 - 17:16 GMT
Identified
Our support team is experiencing issues with inbound calls on our primary system.

Calls are falling back to our back up system however we are operating at a reduced capacity.

We apologise for any inconvenience caused when trying to contact us and we will update this status post within an hour or as soon as any more information becomes available.
Posted Jan 13, 2017 - 15:34 GMT