Reduced Support Availability due to Weather
Incident Report for Gradwell Communications Ltd
Resolved
This incident has been resolved.
Posted Mar 19, 2018 - 19:50 GMT
Monitoring
Due to overnight snowfall the Gradwell Support team will be working at reduced capacity today.

If your query is not urgent, please contact us by email on support@gradwell.com rather than phoning.

We apologise for any inconvenience that this may cause.
Posted Mar 19, 2018 - 07:18 GMT
This incident affected: Portals and Website (Gradwell team).