Hosted Exchange issue
Incident Report for Gradwell Communications Ltd
Resolved
The problem has now been resolved.
Posted Jul 11, 2017 - 13:38 BST
Investigating
Some hosted Exchange customers have reported issues accessing their email. Our Systems Operations team are currently investigating the issue and further updates will follow shortly.
Posted Jul 11, 2017 - 13:29 BST