Sales and Support unavailable 02.05.2024 @ 15:00
Scheduled for May 2, 15:00 - 16:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 23, 2024 - 09:03 BST
Scheduled
Hi,

Please be advised that our Sales & Support teams will be unavailable due to a company update meeting between 15.00 and 16.00 on the 02/05/2024.

Please email the team for anything urgent on:

connectivity@gradwell.com
customerservice@gradwell.com
order.escalation@gradwell.com
tech@gradwell.com

We apologise for any inconvenience this may cause.
Posted May 02, 2024 - 15:00 BST
This scheduled maintenance affects: Portals and Website (Gradwell team).