Network Maintenance Advisory 11/07/2025 00:05:00

Scheduled for Jul 11, 00:05 - 06:05 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 04, 2025 - 11:50 BST

Scheduled

Hi,

During the night of 11/07/2025 one of our suppliers will be undergoing work to improve their network resilience.

All connectivity services, including broadband, FTTC, ethernet, and Fibreline, should be considered at risk for the duration of the maintenance window:

Start date & time: 11/07/2025 @ 00:05:00 GMT
End date & time: 11/07/2025 @ 06:00:00 GMT

Affecting the below areas:

Abbeyhill Acocks Green Banbury Basford Bearwood Bedminster Bristol North Cardiff Empire Chelmsford Coleraine Dagenham Eccles Exeter Failsworth Great Crosby Harehills Headingley Holywell Llanelli Londonderry/Meg Merthyr Tydfil Merton Park Moortown Morley Newington Nottingham Longbow Portobello Pudsey Stone Stoneycroft Swansea Main Thamesmead Walkden Wallasey Waverley Western Whitchurch Wythenshawe


We apologise for any inconvenience caused by this essential maintenance.”
Posted Jul 04, 2025 - 11:48 BST
This scheduled maintenance affects: Connectivity (Fibre line, EFM, ADSL Broadband, FTTC).