Outbound calls via Gradwell SIP Trunks
Incident Report for Gradwell Communications Ltd
Postmortem

Reason For Outage – SIP Trunk Outbound Call Failures 27th March 2022

Issued 31/03/2022

For external use

  • Time: 02:00 – 13:05 GMT
  • Duration: 11 hours, 5 minutes
  • Description of outage: Around 11:00 on the 27th of March 2022, Gradwell support were alerted to outbound call failures on the SIP trunk platform. All outbound calls made over a Gradwell SIP trunk simply failed to route with no distinct error message returned. Gradwell Engineers were fully engaged on the incident which was given a priority one status.
  • Cause & resolution: Our engineers identified the cause of the issue and restored service by rebooting the affected hardware at 13:05. No further failures were observed after the restart and we observed calls passing over the platform without error.
  • Root Cause: Following a routine supplier maintenance window the trunk servers failed to reconnect causing the outage. The maintenance is a monthly occurrence and this failure is an extraordinary event.
  • Prevention of recurrence: Gradwell engineers have deployed a means to force reconnection where required and to log and alert to any failures should they recur.
Posted Mar 31, 2022 - 11:29 BST

Resolved
This incident has been resolved, we apologise for the inconvenience this caused our customers and will provide an RFO within seven (7) days.
Posted Mar 27, 2022 - 13:54 BST
Monitoring
A fix has been implemented and we can now see calls passing without issue. We will monitor closely for any recurrence.
Posted Mar 27, 2022 - 13:12 BST
Investigating
We are currently investigating reports of issues when making outbound calls via Gradwell SIP trunks.

We will provide an update by 14:00 and apologise for the inconvenience this may be causing.
Posted Mar 27, 2022 - 12:59 BST
This incident affected: Voice & Calls Services (Outbound SIP Trunking).