Gradwell Sales & Support teams unavailable
Incident Report for Gradwell Communications Ltd
Resolved
Ours teams are once again available and we thank you for your patience in this matter.
Posted Feb 10, 2020 - 11:02 GMT
Investigating
Hi,

We apologise for the short notice, our sales & support teams will be unavailable due to a company update meeting between 10:30 & 11:00 on 10/02/2020.

Please email the team for anything urgent on:

support@gradwell.com
partnersupport@gradwell.com
sales@gradwell.com

We apologise for any inconvenience this may cause.
Posted Feb 10, 2020 - 09:55 GMT
This incident affected: Portals and Website (Gradwell team).