Gradwell update regarding the Coronavirus

Incident Report for Gradwell Communications Ltd

Resolved

This incident has been resolved.
Posted Apr 15, 2020 - 14:21 BST

Investigating

As your provider we want to keep you up to date with any disruption, not just to our core network, but our suppliers too.

As well as this status page for our own network, we've created a separate page featuring all our key supplier information as soon as we get it. We'll be updating this several times each day:

https://www.gradwell.com/coronavirus/

Our teams are able to operate at full capacity remotely and are constantly helping our customers get the most out of our products and services.

We appreciate your understanding during this unprecedented time.
Posted Mar 25, 2020 - 15:46 GMT
This incident affected: Portals and Website (Gradwell team).